Lanzamiento de Moodle 3.9.2 y el fin de la Versión 3.7

Moodle Hosting

La última versión de Moodle está lista para descargar. Después de ser aprobada y tener un 100% de control de calidad, Moodle 3.9.2 fue lanzada el día 14 de septiembre del 2020 y está disponible finalmente.

La nueva Versión de Moodle presenta nuevas características que mejoraran tu trabajo como estudiante, profesor o administrador.

Disfrutarás de más capacidades y controles en cuanto a una interfaz más atractiva y sencilla.

En su Página oficial se ha publicado las mejoras de la versión 3.9.2 estas incluyen correcciones de errores, así como mejoras de seguridad.

Le recomendamos que actualice sus sitios lo antes posible. Tenga en cuenta que después de la próxima versión menor, el 9 de noviembre, el soporte técnico cesará para Moodle 3.7 (la versión compatible final será Moodle 3.7.9).  

Los Requisitos del servidor para esta actualización son

  • PHP 7.2
  •  MariaDB 10.2.29 ,  MySQL 5.6 ,  Postgres 9.5 , MSSQL 2012 o Oracle 11.2
  • Se requiere la extensión PHP mbstring

En esa misma fecha, Moodle 3.8 entrará solo en soporte de seguridad. Si estás en Moodle 3.7 o 3.8, ahora es un buen momento para planificar tus mejoras.

La siguiente imagen muestra la política de lanzamiento de Moodle esquemáticamente.

Lanzamiento de Moodle

¿Es necesario Actualizar mi versión de Moodle?

La respuesta a esta pregunta es realmente sencilla, si aún estas en versiones anteriores a la versión 3.7.8 la respuesta es sí, aparte de las diferentes características que ofrece las nuevas versiones 3.9 en adelante el soporte técnico cesara para las versiones antiguas, así como parches de seguridad y mejoras avanzadas para todos tus usuarios.  Es recomendable revisar también si tu plan de Hosting o VPS soporta estas nuevas actualizaciones.

¿Mi plan de Hosting o VPS cumple con los requisitos para actualizar mi Moodle?

Si cuentas con un plan de plan de Hosting o VPS en Nodored la respuesta a esta interrogante es sí, nuestro  primer requerimiento fundamental para esta actualización es  contar con la versión de PHP 7.2, en un post anterior se comunicó que PHP 7.2 es  el nuevo predeterminado en Nodored ya que la constante estabilidad, seguridad y velocidad de sus sitios web son de suma importancia para nosotros.

Si no cuentas con un plan de Hosting en Nodored te sugiero que verifiques si tu proveedor de Hosting o VPS cuenta ya con esta versión de PHP ya que el no tenerla, sería un grave problema al querer actualizar o instalar Moodle.

¿Cuáles son los aspectos más importantes que debo tomar en cuenta antes de actualizar Moodle?

Te recomiendo que pruebes la actualización primeramente en una COPIA de tu sitio de producción, de esta manera podrás asegurarte que funciona correctamente.

Respaldo de datos importantes

Hay tres áreas que debe respaldar antes de actualizar:

  • Moodle (Por ejemplo, todo dentro de server (public_html/moodle)
  • Archivos subidos a Moodle (Por ejemplo, /home/moodledata)
  • Base de Datos de Moodle (Por ejemplo, un volcado de su Postgres o MySQL)

Revise la configuración y actualizaciones para sus plugins

Si Usted tiene habilitada la configuración de sus plugins para que se actualicen automáticamente, usted podrá actualizar los complementos instalados de forma automática durante la actualización. Solamente debe asegurarse de revisar la existencia de actualizaciones disponibles en la pantalla de Plugins.

Si Usted actualiza sus complementos (add-ons) de forma manual, éste es un buen momento para revisarlos en el Moodle Plugins directory para ver si existe una versión disponible para su nueva versión de Moodle, incluyendo los temas y gráficos, que hubiera instalado con anterioridad en su sitio.

Related Articles